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Copyright Information 
 

 All material herein is Copyrighted © 2016 Drew Technologies, Inc. 
 

 The DrewLinQ software, hardware, and firmware are also Copyrighted. 
 

 Users are given permission to copy any part of this manual provided that the copy is used with the DrewLinQ 
product and the "Copyright © 2016 Drew Technologies, Inc ." statement remain on all copies.   
 

 "DrewTech" is synonymous with "Drew Technologies, Inc." and is used throughout this manual.   
 

 The “Drew Technologies” logo is a registered trademark of Drew Technologies, Inc. 
 

Notices 
 

 The information contained in this document is subject to change without prior notice. DrewTech shall not be held 
liable for technical, editorial errors, or omissions herein. 

 
 Warranties for DrewTech products and services are set forth in the express written warranty statements 

accompanying the product.  Nothing herein should be construed as constituting any additional warranty.  
 

 DrewTech assumes no responsibility for any damage resulting from the use, misuse, or negligent use of the 
DrewLinQ hardware or any software application used with the DrewLinQ. 
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 Microsoft™ and the various versions of Windows™ are U.S. registered trademarks of Microsoft Corporation. 
 

 Most OEM software applications are registered trademarks of their respective corporations and also carry 
copyright notices. 
 

Safety Information 

 
 

The DrewLinQ is designed to be used by those trained in the diagnostics and reprogramming of vehicles and equipment.  
The user is assumed to have a good understanding of vehicle electronic systems and the potential hazards involved while 
working in a shop environment.  There are numerous safety situations that cannot be enumerated or foreseen, so 
DrewTech recommends that the user read and follow all safety messages in this manual, on all shop equipment, from 
vehicle manuals, as well as internal shop documents and operating procedures. 
 

 Always block/chock all wheels (front and back) when testing.   

 Use caution when working around electricity. There is the risk of shock from vehicle and building-level voltages.  

 Do not smoke, or allow sparks/flame near any part of the vehicle fuel system or vehicle batteries. 

 Always work in an adequately ventilated area.  Route vehicle exhaust fumes to the outdoors. 

 Do not use this product where fuel, fuel vapors, or other combustibles could ignite. 

 
Drew Technologies, Inc. 
3915 Research Park Drive, Suite A10 

Ann Arbor, MI  48108 
Phone:  (734) 222-5228 
www.drewtech.com 

sales@drewtech.com  
support@drewtech.com  

http://www.drewtech.com/
mailto:sales@drewtech.com
mailto:support@drewtech.com
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2.   Introducing the DrewLinQ 

The DrewLinQ is a Vehicle Diagnostic Adapter (VDA) that connects vehicle communication networks to diagnostic or 
reprogramming software running on a Windows-based personal computer (PC).  The DrewLinQ allows software 
applications to read diagnostic information, monitor parameters, perform component level testing, and reprogram vehicle 
Electronic Control Modules (ECMs).   
 
The DrewLinQ supports both the Technology and Maintenance Council (TMC) RP1210 and the Society of Automotive 
Engineers (SAE) J2534 application programming standards. 
 

 
DrewLinQ Standard Kit (PN# DL-LD-HD-KIT) 

Includes 6/9-pin Deutsch "Y" Cable (CBL-DL-FTL-69Y) and Volvo 2013+/OBDII Cable Kit (DL-CBL-VV-KIT-01) 

2.1. Operating Systems Supported 

 Windows 7® 32-bit and 64-bit Versions  

 Windows 8® 32-bit and 64-bit Versions  

 Windows 8.1® 32-bit and 64-bit Versions  

 Windows 10® 32-bit and 64-bit Versions  

2.2. TMC/SAE Standards 

 TMC RP1210D (Draft-September-2016), RP1210C, RP1210B, RP1210A 

 SAE J2534-1, 04.04 and 02.02 Versions 

 J2214/J2461, Vehicle Electronic Programming Station (VEPS)  
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2.3. Protocols Supported 

 CAN (ISO11898-2), 3 High-Speed CAN Channels 

¶ J1939, ISO15765, CAN, PTCAN, J2284/GMLAN, IESCAN 

¶ CAN Automatic Baud Rate Detection Supported 

¶ Supports all CAN baud rates. 

 J1708/J1587 

 SWCAN (J2411) - Single Wire CAN - 1 Channel 

 FTCAN (ISO 11898-3) - Fault Tolerant CAN - 1 Channel 

 ISO9141 (K, K+L, 5-baud init) 

 ISO14230 (K, K+L, 5-baud init, FAST init) 

 J1850 VPW - J1850 Variable Pulse Width 

 J1850 PWM - J1850 Pulse Width Modulation 

 Allison CEC1 

 Automotive Ethernet, ISO13400 (DoIP) 

 ALDL - Assembly Line Data Link

2.4. DrewLinQ Light Emitting Diode (LED) Indicators 

The following is a table of the DrewLinQ LEDs and what each indicator means.  The icons appear left to right. 
 

LED Name Icon Image Description 

Wireless Data 

 

 If flashing, indicates wireless traffic between the PC and the 
DrewLinQ.  This is only for wireless versions of the DrewLinQ. 

USB Data 
 

 LED blinks green indicating active USB data transmissions. 
 LED solid green indicates an active PC connection to the device, 

but no USB data transmission. 
 LED off indicates you have vehicle power and a USB port 

connection, but not connected and no USB data transmission. 
 LED is red if plugged into vehicle power, but not into a USB port. 

Vehicle Power 

 

 LED on, indicates power from the vehicle or external power. 

Vehicle Data 

 

 Blinks to indicate messages are being seen on the data bus. 
 Solid green if a “software connection” has been made. 

Power 

 

 Solid green indicates power to the microprocessor. 
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3.   Installing the DrewLinQ 

 

STOP!!! 
 

 
 

Please Read The Following Instructions!!! 
 

1. Log onto the PC as an Administrator.  The account you log into must have Administrator privileges 

to install the drivers. 

 

2. Connect your PC to the Internet.  Internet access is required to activate the DrewLinQ.  The 

DrewLinQ cannot be used until it is activated.  You can run the install and then activate the 

DrewLinQ at a later date, however it will not work until it has been activated.  If you need to 

activate it later, the instructions for doing so are in "Chapter 4,  Activating the DrewLinQ". 

 

3. Run the DrewLinQ installation (DrewLinQ_Setup.exe) from the DrewLinQ CD. 

  

4. Follow onscreen instructions to complete product installation and activation. 

3.1.   If Install Does Not Run When Inserting the CD into the PC 

If setup does not begin automatically, you ran manually run the install through the Windows Start Menu: 

Start → All Programs → Accessories → Run → [CD_Drive]:\DrewLinQ_Setup.exe and click OK 

3.2.   Latest Drivers 

The latest drivers are always available for download at www.drewtech.com. 

http://www.drewtech.com/
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4.   Activating the DrewLinQ 

To help deter unauthorized hardware reproductions (a.k.a. "knock-offs" or "clones"), each DrewLinQ must be activated 
before it can be used.  The activation process is part of the installation, however if an internet connection is not available 
during installation,  it can be ran at any time from the Windows Start Menu: 
 

 Start → All Programs → Drew Technologies, Inc. → Universal Activator → DrewTech Activator 

The activation process is simple.   

 Ensure you have a good internet connection and then plug the DrewLinQ into the PC. 

 Run the activator which is part of the installation, or from the Windows Start Menu.  The following screen appears: 

 
 

 Press the "Activate My Device!" button and the following screen will be displayed.  Select the "DrewLinQ" entry 

and press the "Continue" button. 

 
 

 The next screen will be displayed.  Please fill out the form in its entirety and press the "Continue" button.  

DrewTech uses this information for warranty purposes and not for unsolicited e-mails or telephone calls (SPAM).  

We may send information from time to time about updates to drivers or other pertinent product information.  
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 The next screen will be displayed asking which OEMs or component suppliers you provide service for and how 
experienced you are at diagnostics and reprogramming.  This allows us to send specific product bulletins.  Please 
select each OEM or component supplier and after filling in the data, press the "Continue" button.  
 

 
 

 The next steps ensure the DrewLinQ can be recognized by the PC after a disconnection (USB drivers properly 

installed and working).  Press the OK button after removing the DrewLinQ from the PC.  After the activator sees 

the DrewLinQ removed, it will tell you to reinsert it.  After the activator sees the DrewLinQ, it will bring up another 

dialog box.  Press OK to continue.   

 
 

 After the activator has seen the DrewLinQ device disconnect and connect, it will send the information to a 

DrewTech server and complete the product activation.  Press the "Close Application" button to continue.   

 

  



DrewLinQ User Manual 

 
Page 10 / 30 © 2016 Drew Technologies, Inc. 

 

5.   Troubleshooting the DrewLinQ with VDA Validation Tool (VVT) 

Most support calls are from users who have not correctly configured  
the application to use the DrewLinQ or who have selected the incorrect protocol and/or CAN channel.   

The VVT application is the first tool that DrewTech support personnel use to troubleshoot the DrewLinQ. 
 
If the application you are running is having trouble using the DrewLinQ, read the chapter in this manual (Setting Up 
RP1210 Applications) on configuring the application to use the DrewLinQ.  If you have ensured the application is 
configured properly, you can use the VDA Validation Tool(VVT) to troubleshoot the DrewLinQ.  DrewTech encourages 
DrewLinQ users to use VVT to ensure end-to-end communications before starting any application using the DrewLinQ.   
 
The VVT application: 

1. Ensures the VDA drivers are installed properly. 

2. Determines if the PC can communicate with the DrewLinQ. 

3. Determines if the DrewLinQ can see messages on the vehicle.   

4. Provides information about the version of drivers and firmware that are installed. 

5. Provides information about the PC (Windows version, memory, Java, .NET, etc). 

 
Here are the basic troubleshooting steps: 
 
1. Connect the DrewLinQ to the vehicle and ensure the Vehicle Power LED is illuminated.  

1.1. Not seeing the Vehicle Power LED illuminated usually indicates the ignition key is not on.  The PC will be able to 

see the DrewLinQ, but the DrewLinQ will not be able to read messages from the vehicle databus. 

2. Connect the DrewLinQ to the PC and ensure the Power LED is illuminated.  

2.1. Not seeing the Power LED illuminated usually indicates an inoperative USB port (very common among heavily 

used service-bay diagnostic PCs).  Try another USB port until the LED becomes illuminated and you can hear 

the "dah-ding" Windows "USB device found" sound. 

3. Start the VDA Validation Tool (VVT) application using the icon on the desktop. 

 

VVT Main Screen (RP1210 Test) 

4. Follow the instructions in the next chapters for troubleshooting using the RP1210 or J2534 standards. 
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6.   Troubleshooting RP1210 Devices  

Most Heavy-Duty (HD) and Medium-Duty (MD) applications are based on the TMC RP1210 standard.  Click on the icon of 
the truck if your application uses the RP1210 standard.  The most common connectors for HD/MD are the 6-pin or 9-pin 
Deutsch connectors (typically grey, black, or green).  The most common protocols for HD/MD are J1939 and J1708.  For 
the 2013 (or newer) Volvo chassis with Volvo engine that has the OBDII connector, see "Appendix A - Volvo/Mack 2013 
and Newer Vehicles" for the special description and testing required of this platform.   

6.1.   Common HD/MD Connectors and Typical Protocols to Test 

This table shows the most commonly found connectors and the potential protocols on them.  It also shows what 
can be tested using the "simple" Vendor/Device/Protocol test, and also what can be tested using the "Advanced 
Settings" information (CAN Channel/Baud Rate).   
 

Connector 

   

 

Connector 6-pin Deutsch 9-pin Deutsch J1939 Type I - Black 9-pin Deutsch J1939 Type II - Green Volvo 2013 and Newer (Modified OBDII) 

Simple Test  J1708 
 J1708 
 J1939 

 J1708 
 J1939 

 J1708 
 ISO15765 
 CAN 

Advanced 
Settings Test 

 None 

 CAN on Channel 1/2, Auto Baud 
 J1939 on Channel 1/2, Auto Baud 
 ISO15765 on Channel 1/2, Auto Baud 
 IESCAN on Channel 1/2, Auto Baud 

 J1939 on Channel 1/2/3, Auto Baud 
 CAN on Channel 1/2/3, Auto Baud 
 ISO15765 on Channel1/2/3, Auto Baud 
 IESCAN on Channel 1/2/3, Auto Baud 

 CAN on Channel 1/2/3, Auto Baud 
 J1939 on Channel 1/2/3, Auto Baud 
 ISO15765 on Channel 1/2/3, Auto Baud 

6.2.   Validating a J1939 or J1708 Vehicle - Simple Test 

If you are connecting to a J1708 or J1939 vehicle that is using a black or grey 6-pin or 9-pin Deutsch connector, 
follow these instructions.  If you are connecting to a J1939 vehicle with a green 9-pin Deutsch connector you will 
need to use the "Advanced Settings" fields (next subsection).   

 
1) Select the DrewLinQ using the Vendor, Device, Protocol dropdown boxes: 

 
Vendor:  DREWLINQ - DrewLinQ - Drew Technologies, Inc. 
Device:   DrewLinQ, USB 
Protocol:  J1939 or J1708  

 

 
 

Selecting DrewLinQ and the J1939 Protocol 
 

2) Click the Validate button.  

 
3) The possible test results are described below in section "6.4. Validation Test Results". 
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6.3.   Validating J1939@500k or Multi-CAN-Channel Vehicles  - Advanced Settings 

If you are connecting to a vehicle using the new green 9-pin Deutsch connector, or you want to check the status of 
a CAN channel other than CAN channel 1 (the default), follow these instructions.   
 
1) Click the hyperlink ">> Show Advanced Settings".  

 
2) Select the DrewLinQ using the Vendor, Device, Protocol dropdown boxes: 

 
Vendor:  DREWLINQ - DrewLinQ - Drew Technologies, Inc. 
Device:   DrewLinQ, USB 
Protocol:  J1939, CAN, or ISO15765 
Channel:  1 or the CAN channel you want to test with 
Baud Rate:  Auto 

 

 
 

Selecting DrewLinQ and the J1939 Protocol (CAN Channel 1, Auto Baud Detect) 
 

3) Click the Validate button.  

 

4) The possible test results are described below in section "6.4. Validation Test Results". 
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6.4.   Validation Test Results 

6.4.1. Green/Green - PC to DrewLinQ Successful, DrewLinQ to Vehicle Successful 

 The green arrows between the picture of the PC and the picture of the DrewLinQ indicate that there was a 

successful connection between the PC and the DrewLinQ device.   

 The green arrow between the picture of the DrewLinQ and the picture of the truck indicate that there were 

messages seen on the vehicle. 

 
 

6.4.2. Green/Red - PC to DrewLinQ Successful, DrewLinQ to Vehicle Failure 

 The green arrows between the picture of the PC and the picture of the DrewLinQ indicate that there was a 

successful connection between the PC and the DrewLinQ device.   

 The red arrow between the picture of the DrewLinQ and the picture of the truck indicate that there were no 

messages seen on the vehicle using the selected protocol (and/or CAN channel). 

 It is possible the ignition is turned off, or the wrong protocol/CAN channel was selected. 

 

6.4.3. Red/Blank - PC to DrewLinQ Failure, DrewLinQ to Vehicle Not Tested 

 The red arrows between the picture of the PC and the picture of the DrewLinQ indicate that there was a 

failure connecting to the DrewLinQ.   

 Since connecting to the DrewLinQ failed, there were no attempts to read messages from the vehicle... 

 Try a different USB port on the PC.  If that fails, reboot the PC and retry all USB ports.   
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6.5.   Troubleshooting Suggestions and Next Steps 

After a test has been completed, a window will appear with instructions on how to self-diagnose and resolve 
potential issues.  For example: 

 

 If you get Green/Green (image on the top left), the DrewLinQ is working perfectly.  Your focus should be on 

configuring your application to use the DrewLinQ and/or select another protocol or CAN channel.   

 

 If you get Red/Blank (image on the top right), then there is something wrong with the USB port or drivers that 

is keeping the PC from seeing the DrewLinQ.  You should probably focus on USB ports.   

 

 If you get Green/Red (bottom image), then VVT could not see or provoke a response on the selected protocol 

(and/or CAN channel).  You should try another protocol, CAN channel, and ensure the ignition is turned on.  

Following these instructions will probably resolve your problem, however if after trying all of the protocols 
mentioned for your connector, don't hesitate to call our technical support personnel at (734) 222-5228; Option 3. 
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7.   Troubleshooting J2534 Devices 

The VVT application does not yet support troubleshooting of J2534 devices.  If you need help troubleshooting a J2534 
application using the DrewLinQ, don't hesitate to call our technical support personnel at (734) 222-5228; Option 3. 
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8.   Heavy-Duty and Medium-Duty Software Compatibility 

DrewLinQ has Technology and Maintenance Council (TMC) RP1210D (Draft-September-2016), RP1210C, RP1210B, and 
RP1210A compliant drivers.  Any application that claims to be completely RP1210 compliant should work as long as the 
DrewLinQ supports the protocols needed by that application.  DrewLinQ has been validated with the most common OEM 
and component applications: 

 
 Allison DOC 

 Bendix ACOM 

 Caterpillar Electronic Technician
*
 

 Cummins INSITE™  

 Cummins INSITE™ Fault Viewer 

 Cummins PowerSpec 

 Dana Diagnostic Tool  

 Detroit Diagnostic Link 

 Eaton ServiceRanger 

 International Diamond Logic Builder  

 International NavKal 

 International ServiceMaxx (J1939, J1708) 

 Meritor-WABCO Toolbox 

 Noregon - JPRO
tm

 Professional 

 PACCAR DAVIE** 

 Perkins EST
*
 

 PocketFleet PF-Diagnose 

 RA Consulting - Silver Scan Tool 

 Volvo/Mack Premium Tech Tool (PTT) 

 
 

*   See the addendum on CAT ET for special notes regarding this software. 

**   Supposedly PACCAR DAVIE is RP1210 compliant, but has not been tested. 

 

Below are specialty apps, outdated apps, or are being replaced.  The DrewLinQ should work with them as well. 

 

 Detroit Diesel Diagnostic Link  

 Detroit Diesel Reprogramming Station  

 Freightliner ServiceLink 

 International InTune 

 International IPC Fleet 

 International Master Diagnostics 

 Mack/Volvo VCADS 

 Vansco VMMS 

 ZF-Meritor TransSoft 
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9.   Light-Duty/Medium-Duty J2534 Software Compatibility 

DrewLinQ has SAE J2534 compliant drivers that support the J2534 04.04 and J2534 02.02 API standards.  Any 
application that claims to be completely J2534 (04.04) or J2534 (02.02) compliant should work as long as DrewLinQ 
supports the protocols and features needed by that application.  

  
 If your OEM diagnostic/reprogramming software is not listed, it may still work.  In the event it does not, a 

DrewTech CarDAQ or a Mongoose product should work.  Feel free to contact DrewTech with any questions. 
 

DrewLinQ is able to diagnose and reprogram vehicles using the J1850VPW, J1850PWM, ISO9141, ISO14230, and 
ISO15765 OBDII/J1979 protocols with the following exceptions: 

 
 DrewLinQ does not support the application of a programming voltage, nor grounding of pins, which are needed for 

various reprogramming applications.  For these vehicles, the CarDAQ or Mongoose is the best option.  Feel free 
to contact DrewTech with any questions. 
 

DrewLinQ has been validated against the following applications using the following protocols: 
 

 Chrysler J2534 Application (11-bit CAN) 

 DashLogic - PassThruScope (11-bit/29-bit CAN, ISO15765, J1850VPW, J1850PWM, ISO9141, ISO14230) 

 Ford Module Programming (CAN Vehicles) 

 General Motors SPS (J1850VPW/11-bit CAN) 

 General Motors GDS2 (11-bit CAN on  pins 6,14) 

 Hino DIAGNOSTIC EXPLORER (DX2) 

 Toyota CUW (11-bit CAN) 

9.1.   Setting Up J2534-Compliant Applications 

Setting up and reprogramming using a J2534-compliant application is not part of this manual.  DrewTech offers 
many videos describing the diagnostic adapter selection, also known as Vehicle Communications Interface (VCI), 
and reprogramming processes.  They can be found at www.drewtech.com.   

 
 
 

www.drewtech.com
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10.   Setting Up Common Applications for the DrewLinQ 

This section shows how to configure the most common RP1210-compliant applications to work with the DrewLinQ.  Since 
Hino is a medium-duty vehicle so Hino DX2 (a J2534 application) is included in this section as well. 

10.1. Allison DOC 

1. Click the F4-Connect to vehicle icon. 
2. Select the correct transmission type. 
3. Uncheck Smart Connect. 
4. Click Connect. 
5. Click Advanced Setup. 
6. Select vendor of DREWLINQ. 
7. Select protocol of J1939 or J1708. 
8. Select correct device of DrewLinQ, USB 
9. Click OK. 

10.2. Bendix ABS Diagnostics 

1. Click the Communication Device Options icon. 
2. Select DrewLinQ, USB 
3. Click the green check mark icon. 

10.3. Caterpillar Electronic Technician (CAT ET) and Notes 

1. Click Utilities → Preferences → Communications from the menu bar. 
2. Click on Communication Interface Device dropdown box. 
3. Select RP1210 Compliant Device. 
4. Click Advanced 
5. Select DrewLinQ, USB. 
6. Click OK 
7. Check Enable Dual Data Link Service* 
8. Click OK. 
 

 Enable Dual Data Link.  This checkbox should be checked for most cases.  However, some older J1708 
(ATA) only vehicles and industrial stationary equipment will not work with it checked.  If ET does not connect, 
uncheck this box. 

 

 The DrewLinQ product line does not support the CAT Data Link (CDL) protocol that is still common among 
certain CAT off-highway vehicles and industrial stationary equipment.  CDL is a proprietary protocol and 
requires you go to your local CAT distributor and purchase a CAT adapter.  To determine if you need to 
purchase a CAT branded adapter, see "Appendix B - CAT Electronic Technician (ET) Compatibility".   
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10.4. Cummins INSITE 

1. File → Connections → Add New Connection. 
2. Click Next. 
3. Click radio button for RP1210 Adapters and click Next. 
4. Select correct vendor, device, and choose Auto Detect for the protocol: 
5. DrewLinQ - Drew Technologies, Inc. 
6. DrewLinQ, USB 
7. Auto Detect 
8. Click Next. 
9. Name the connection "DrewLinQ-USB - Auto Detect - RP1210A" 
10. Click Next 
11. Click on make this connection active. 
12. Click Finish 

 
 If you want to define a DrewLinQ entry for J1708 and J1939 individually, you can repeat steps 1-4 and 

name the entries based on the protocol, for example "DrewLinQ-USB - J1939 - RP1210A" 

10.5. Dana Diagnostic Tool 

1. Under Adapter Selection, choose DrewLinQ - Drew Technologies, Inc.: DrewLinQ, USB 
2. Select Connect J1708 or Connect J1939 depending on your ECM. 

10.6. DashLogic - PassThruScope 

1. Under Connection Settings section, click "Add Channel". 
2. Give the channel a descriptive name such as "CAN1-250k", "CAN1-500k", etc. 
3. Select DrewLinQ under J2534 Device.  The J2534 Driver will be filled in automatically. 
4. Select Device Instance of 0. 
5. Select the protocol you want attached to this channel (i.e. CAN). 
6. Choose the baud rate desired for the protocol, such as 250000 or 500000. 
7. Select the connector you are using and which pins the protocol is on (i.e. J1962 Pin 6 & 14). 
8. Either set specific connect flags (not usually needed), or just Click OK. 
9. Click the "Save Config" button on the menu bar and save the configuration to a file. 

10.7. Detroit DiagnosticLink 8 

1. Click Tools → Options → SID Configure. 
2. Select DrewLinQ, USB. 
3. Click OK. 

10.8. Eaton ServiceRanger 

1. Choose Go To → Settings 
2. Choose "DrewLinQ - Drew Technologies, Inc. (DREWLINQ) 
3. Select the correct J1587 and J1939 options for the vehicle you are connecting to. 
4. For J1939, choose the correct CAN channel, and use the "Speed:Auto" setting. 
5. Click Apply. 

10.9. Hino DIAGNOSTIC EXPLORER (DX2) 

1. Click Settings (S) → Communication setting (D) 
2. In the “Select Interface” dropdown select DLNQ0202. 
3. Click OK. 
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10.10. NAVISTAR ServiceMaxx J1708 

1. Choose Tools → Select Com Link → DrewLinQ - Drew Technologies, Inc → DrewLinQ, USB 

10.11. NAVISTAR ServiceMaxx  

1. Choose Tools → Select Com Link → DrewLinQ - Drew Technologies, Inc → DrewLinQ, USB 
2. Select either J1939 or KWP2000 depending on your ECM. 

10.12. NAVISTAR Diamond Logic Builder (DLB) 

1. Choose Tools → Select Com Link → DrewLinQ - Drew Technologies, Inc → DrewLinQ, USB 

10.13. Meritor-WABCO Toolbox 

1. Click Utilities Icon 
2. Select DrewLinQ - Drew Technologies, Inc.  
3. Select the protocol to use based on the vehicle connection, J1939 or J1708. 
4. Select DrewLinQ, USB. 

10.14. Noregon JPRO(tm) Professional 

1. Instructions for this application are pending. 

10.15. PocketFleet PF-Diagnose 

1. Click Tools → Setup Defaults. 
2. Under Select Primary Protocol: 

a. J1939 HD and Ind.   
3. Under CAN Channel: 

a. Select the correct CAN channel (CAN 1 is most common). 
4. Check the "Connect with both J1708 and J1939"  checkbox. 
5. In both "RP1210 Adapter" and "J2534 Pass-Thru" boxes, select the DrewLinQ. 
6. Click the Save button. 

10.16. RA Consulting Silver Scan Tool 

1. Click Options → Interface 
2. Select table entry showing DrewLinQ, USB and Interface Type of RP1210 (for J1939) or Interface Type of 

PassThru for OBDII protocols. 

10.17. Volvo/Mack Premium Tech Tool (PTT) 

1. Click Settings icon. 
2. Click Communication Unit tab. 
3. Click Configuration icon. 
4. Select Advanced Settings button. 
5. Select DrewLinQ. 
6. Click the OK button. 
7. Select the DrewLinQ entry in the Communication Unit  tab and press the Activate button. 
8. Select the OK Button. 

 
 Volvo/Mack PTT is very finicky about VDA connections.  Never press the "Connect" button.  If you do the 

connection usually fails.  Just wait a few minutes for PTT to establish its own connection.  If connection 
doesn't occur, re-boot the PC.   
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11.   Product Specifications 

11.1. DrewLinQ Physical and Electrical 

Feature Data 

Dimensions (approximately) 6" (length) x 3.75 (width) x 1.25" (height) 

Voltage Requirements 8 to 32 Volts DC 

Current Requirements 300mA maximum within voltage range 

Operating Temperature Range 0 to 70 Degrees Celsius 

PC Communications Type USB Version 1.1 or Higher 

11.2. DrewLinQ Pinouts High-Density DB26 

Pin Protocol 1 Protocol 2 Protocol 3 Protocol 4 

1 SW_CAN FT_CAN+          

 2 J1850+ (VPW/PWM)                    

 3 CAN2+ GM_UART DoIP Ethernet TX+ CEC1 Enable  

 4 Case Ground                        

 5 Signal/Battery Ground     

 6 CAN1+                 

 7 ISO9141/ISO14230 K-Line J1708+ (J2534 PS)   

 8 DoIP Ethernet Sense                     

 9 CEC1 FT_CAN-                     

10 J1850- (PWM)                    

11 CAN2- ISO9141/ISO14230 K-Line DoIP Ethernet TX-       

12 J1708+ (Primary) CAN3+ DoIP Ethernet RX+ GM_UART     

13 J1708- (Primary) CAN3- DoIP Ethernet RX-       

14 CAN1-       

15 ISO9141/ISO14230 L-Line J1708- (J2534 PS)                    

16 V+ Battery (8-32V)          

17 Do Not Connect    

18 Do Not Connect    

19 Reserved/TBA                                 

20 Do Not Connect    

21 Do Not Connect    

22 Do Not Connect    

23 Do Not Connect    

24 Reserved/TBA                        

25 Reserved/TBA                        

26 Signal/Battery Ground     
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12.   Technical Support and Return Merchandise Authorization (RMA) 

12.1. Technical Support 

Technical support is available from 8:30 a.m. to 5:30 p.m. Eastern Time. 
 

 

DrewTech Technical Support 
 
Phone:  (734) 222-5228 Option 3 
E-mail:  support@drewtech.com  
 

12.2. Return Merchandise Authorization (RMA)  

If Technical Support has determined a physical problem may exist, they will issue an RMA number.  Please return 
the DrewLinQ and all cables along with any proof of purchase to the following address: 
 

 

DrewTech Product Support 
Attn:  RMA# xxxxxxxxx 
3915 Research Park Drive, Suite A10 
Ann Arbor, MI  48108 
(734) 222-5228 

 
 
 

mailto:support@drewtech.com
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13.   Appendix A - Volvo/Mack 2013 and Newer Vehicles 

This section is applicable only for the 2013 and newer Volvo/Mack chassis that have Volvo engines and are using the 
OBDII connector.  This section does not apply to a Volvo/Mack chassis that has a Cummins engine using the 9-pin 
Deutsch connector. 
 
Starting in model year 2013, Volvo/Mack introduced a new diagnostic connector for a Volvo/Mack chassis with a Volvo 
engine. The connector is roughly based on the SAE standard J1962/OBDII connector commonly seen in automobiles.  It 
contains two separate CAN channels as well as J1708: 
 

 CAN1 is using the ISO15765 protocol. 

 CAN2 is the J1939 protocol.   

 The J1708/J1587 protocol is also in the connector. 

Below are the pinouts of the connector and the usage by Volvo as compared to the OBDII standard.  

Pin Volvo Function CAN J1962/OBDII Standard 

1   N/C 

2   J1850 VPW/PWM+ 

3 J1939+ CAN2+ Ford DCL+ (Argentina/Brazil Pre-OBDII) 1997-
2000 4   Chassis Ground (Vehicle Ground) 

5 Ground  Signal Ground 

6 ISO15765+ CAN1+ CAN+ 

7   ISO9141/ISO14230 K-Line 

8   N/C 

9   N/C 

10   J1850- 

11 J1939- CAN2- Ford DCL+ (Argentina/Brazil Pre-OBDII) 1997-
2000 12 J1708+  N/C 

13 J1708-  N/C 

14 ISO15765- CAN1- CAN- 

15   ISO9141 L-Line 

16 Power  Power 
 

 

13.1. Connector and Component (i.e. Transmission, ABS) Application Issues 

The second CAN channel and J1708 are not part of the OBDII standard, but the second CAN channel on pins 3, 
11 is  becoming somewhat commonplace.  However, placing the J1708 protocol on pins 12, 13 is a proprietary 
implementation and requires a special cable (or set of cables) to handle this scenario.  This section describes the 
choices faced by VDA vendors, DrewTech's solution, and how to apply DrewLinQ cables to perform diagnostics on 
this platform.  This section also shows the settings to use for VVT when testing this platform. 

 
The underlying issue regarding special cabling is not because of J1708, the two CAN channels, or the Volvo PTT 
application.  The Volvo PTT application automatically handles the connections between CAN1 and CAN2 as well 
as J1708.  The issue is with component applications (i.e. transmission, ABS) and J1939 being on CAN2.   
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RP1210 was developed before multiple CAN channels appeared on vehicles, so when an application connects to 
"J1939", "CAN", or "ISO15765", the VDA directs the connection to CAN1.  RP1210 was modified to allow 
connecting to any CAN channel, and allowing the application to let the VDA do automatic CAN baud rate detection.  
At the time of fielding this vehicle, PTT implemented scanning CAN channels and using automatic baud rate 
detection, however some component applications still have not.  There was no way other than special cabling to 
place J1939 (CAN channel 2) on CAN channel 1 and to also to pass the J1708 protocol.  This left two scenarios for 
VDA vendors as far as cabling: 

 
1) Create a special Volvo cable that crosses CAN1 to CAN2 and vice versa along with passing the J1708 

protocol.  Both PTT and the component applications work in this single cable scenario.  However, the cable in 

this solution is not OBDII compliant.  If a customer wants to work on an OBDII vehicle, they have to purchase 

a separate OBDII compliant cable. 

 
2) Create an OBDII compliant cable that also passes J1708, and then create a second "crossover cable" that 

crosses CAN1 to CAN2 and vice versa along with passing J1708.   This allows the component applications to 

work.  It also allows the user to remove the crossover cable and work on OBDII compliant vehicles. 

DrewTech chose the second way because the cost of the two OBDII connectors and small length of cable are far 
less than the price of a second complete cable.  This cost savings is passed along to our customers.  

 

 
CBL-DL-VV-OBD-T2 

Volvo 2013+/OBDII Compliant Cable 
 

 
CBL-DL-VV-XO 
XOVER Cable 

Volvo 2013 and Newer Cable Kit (DL-CBL-VV-KIT-01) 

13.2. Cable for Volvo PTT or OBDII Applications 

Use the CBL-DL-VV-OBD-T2 cable by itself for running Volvo PTT on this platform.  You can also use this cable 
for any OBDII compliant application.  The cable also has a standard J1939 Type II connector which allows the user 
to work on the most common HD vehicles (up to 3 CAN channels) without having to switch out cables. 

13.3. Cable for Component Applications 

Connect the CBL-DL-VV-XO (XOVER) cable  to the CBL-DL-VV-OBD-T2 cable when you want to use component 
applications on this platform (i.e. transmission, ABS).  This cable crosses CAN2 to CAN1 and vice versa and also 
passes the J1708/J1587 protocol.    
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13.4. Using VVT to Test This Platform - J1708 

Connect only the CBL-DL-VV-OBD-T2 to the DrewLinQ and set up VVT to the following: 
 

 

13.5. Using VVT to Test This Platform - J1939 (CAN Channel 2 - Auto Baud Detect) 

Connect only the CBL-DL-VV-OBD-T2 to the DrewLinQ and set up VVT to the following: 
 

 

13.6. Using VVT to Test This Platform - ISO15765 (CAN Channel 1 - Auto Baud Detect) 

Connect only the CBL-DL-VV-OBD-T2 to the DrewLinQ and set up VVT to the following: 
 

 
 
 



DrewLinQ Installation and User Guide 

 
Page 26 / 30 © 2016 Drew Technologies, Inc. 

 

14.   Appendix B - CAT Electronic Technician (ET) Compatibility 

This addendum deals with CAT ET and whether it will work with the DrewLinQ, and if so, whether you will need to 
purchase the special DrewLinQ cable (CBL-DL-CAT-EQ).  
 

 The DrewLinQ works on CAT engines and equipment that use the J1939 and/or J1708/J1587/ATA protocols.   
o You may be able to use the standard DrewLinQ 9-pin Deutsch vehicle cable. 
o You may have to purchase the DrewLinQ CAT cable (CBL-DL-CAT-EQ). 

 
 The DrewLinQ will not work on CAT engines and industrial stationary equipment using only the proprietary CAT 

Data Link (CDL) protocol.   
o If your CAT engine/equipment only uses the CDL protocol, then you will be required to purchase the 

proprietary CAT adapter.  Continue reading to determine if this is necessary. 
 
The top illustration shows the SAE standard J1939 connector in contrast to the CAT Proprietary Connector below.  The 
DrewLinQ J1939 Type II cable (lime green) will fit both types (J1939 Type I, J1939 Type II).  If the vehicle or equipment 
with the CAT engine uses either one of these connectors, the DrewLinQ will work with that vehicle.   
 

 Note that the "A pin" has a keyway (see green arrow), whereas the CAT connector below does not.   

 Note that the Ground/Power pins on the CAT connector are reversed compared to the SAE standard.  Cutting the 
"A pin" key off of the standard DrewLinQ cable will not allow it to work because the J1708/J1587/ATA protocol 
and the J1939 protocol are on different pins.    

 

Pin J1939 Type I J1939 Type II 

A Ground Ground 

B Power Power 

C CAN1/J1939 Hi CAN1/J1939 Hi 

D CAN1/J1939 Lo CAN1/J1939 Lo 

E CAN1/J1939 Shield CAN1/J1939 Shield 

F J1708/J1587/ATA Hi J1708 or CAN3 Hi 

G J1708/J1587/ATA Lo J1708 or CAN3 Lo 

H OEM Specific OEM Specific or CAN2 Hi 

J OEM Specific OEM Specific or CAN2 Lo 
 

 

 
J1939 Standard 
Type I or Type II 

Pin CAT Proprietary Connector 

A Power 

B Ground 

C CAN1 Shield 

D CAT Data Link (CDL) Hi 

E CAT Data Link (CDL) Lo 

F CAN1/J1939 Lo 

G CAN1/J1939 Hi 

H J1708/J1587/ATA Lo 

J J1708/J1587/ATA Hi 
 

 
 

 
CAT Proprietary Connector 

 
If you have the CAT Proprietary Connector and A/B (Power/Ground) and D/E (CDL) are populated, you need to purchase 
the CAT branded diagnostic adapter and associated cabling from your local CAT dealership.   
 
If A/B (Power/Ground) pins and F/G (J1939) or H/J (J1708/J1587/ATA) are populated, you can use your DrewLinQ; 
however you will need the special DrewLinQ CAT cable(CBL-DL-CAT-EQ). 
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15.   Addendum C - DrewLinQ Cables 

 

 

CBL-DL-FTL-69Y 

¶ Most commonly sold cable for MD/HD vehicles 
with a 6 or 9-pin SAE J1939 standard Deutsch 
Type I (black) or Type II (green) connector.   

¶ 6-Pin covers 1995 to present Class 4-8 MD/HD 
OEMs and suppliers.  Protocols: 

o J1708/J1587 

¶ 9-Pin covers 1998 to present Class 4-8 MD/HD 
OEMs and suppliers.  Protocols: 

o J1708, J1939, CAN1, CAN2, CAN3. 

¶ Compatible with Freightliner Cascadia. 

¶ Compatible with PACCAR Class 8 (and “Baby 8”) 
trucks built on and after 2010 (Dual-CAN) as well 
as after 2016 (Tri-CAN). 

 

CBL-DL-FTL-9 
¶ Same wiring as CBL-DL-FTL-69Y however does 

not include the Deutsch 6-pin connector. 

 

DL-CBL-VV-KIT-01 

¶ Compatible with Volvo 2013 and newer vehicles 
with the modified J1962/OBDII connector. 

¶ The 9-pin Deutsch is wired the same as the CBL-
DL-FTL-69Y and CBL-DL-FTL-9). 

¶ See chapter on Volvo/Mack PTT. 

 

CBL-DL-OBD2 
¶ Generic J1962/OBDII cable. 

¶ Works on all standard OBDII vehicles. 

 

CDP2-CBL-OBD-02 PGM 

¶ Complete OBDII cable passing all 16 pins from 
the OBDII connector to the DrewLinQ. 

¶ Used for SWCAN and FTCAN applications. 

¶ Same cable that comes with the CarDAQ-Plus 2 

 

CBL-DL-CAT-EQ 

¶ Works on CAT equipment (off-highway, 
industrial-stationary) using J1939 and/or 
ATA/J1708/J1587 data buses.  Will not work on 
CAT equipment using CAT Data Link (CDL) 
protocol. 
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CBL-DL-VVE-14 
¶ Volvo Construction Equipment  

¶ 14-Pin Round Cable 

 

CBL-DL-VVE-8 
¶ Volvo Construction Equipment  

¶ 8-Pin Square Cable 

 

CBL-DL-KME-12 
¶ Komatsu Construction Equipment  

¶ 12-Pin Deutsch Cable 

 

CBL-DL-GMC-TK 

¶ GMC Topkick/Kodiak Cable  

¶ Also works on some Isuzu F-series models 
using the J1708/J1587 protocol. 

¶ Modified J1962/OBDII 

 

 

CBL-DL-J1939-BB 

¶ J1939-11 Backbone Cable for use on J1939-11 
Twisted-Shielded-Pair (TSP) networks using the 
Deutsch 3-pin triangle connector. 

¶ Comes with 20 foot battery/power cable with 
battery clips and banana plugs. 

 

CBL-DL-PC-NV-KJ 
¶ PACCAR/NAVISTAR Type I (Black Connector) 

with K-Line (ISO9141) communications on Pin J. 

 

CBL-DL-C3C1 

¶ The CAN3 – CAN1 crossover cable is designed 
for use on 2016 vehicles, including Peterbilt, 
Kenworth and Volvos with Cummins engines. 
The product provides the ability to move 
J1939/CAN3 diagnostic communications over to 
the J1939/CAN1 channel.   

¶ CAN1->CAN3 

¶ CAN2->CAN2 

¶ CAN3->CAN1 

¶ Power/Ground->Power/Ground 
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16.   Appendix D - Sample Source Code for Software Developers 

DrewTech's goal is to provide a comprehensive set of RP1210 and J2534 sample source code for engineers.  The goal is 
to show all software engineering concepts for using either the RP1210 or J2534 API, including: 
 

 Declaring RP1210 and J2534 function headers, and function pointers. 

 Loading the Dynamic Link Library (DLL) and then assigning function pointers. 

 Opening a protocol and setting filters. 

 Reading messages, printing messages to the screen, and decoding message data into engineering values. 

 Sending messages, printing transmitted messages to the screen, and encoding engineering values to be sent. 

 Disconnecting from the data bus, releasing resources and releasing the DLL.  

 
Currently there is only RP1210 sample source code in the C++ language.   
 
The source code will be in the following directory: 
 

 C:\Program Files\Drew Technologies, Inc\SampleSource\RP1210 
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17.   Appendix D - Warranty Information and Limitation Statements 

17.1. Warranty Information - Two Year Limited Warranty on DrewLinQ Hardware 

The DrewLinQ product is warranted to be free from defects in materials or workmanship for two years from the 
date of purchase.  Within this period, DrewTech will, at its sole option, repair or replace any component that fails 
under "normal" usage.  Such repairs or replacement will be made at no charge to the customer for parts or labor; 
however in no event shall DrewTech liability exceed the initial price paid for the DrewLinQ. 
 
If the product proves defective during this warranty period, contact DrewTech Technical Support in order to obtain 
a Return Merchandise Authorization (RMA) number.  The customer is responsible for shipment of the defective 
product to DrewTech.  When returning a product, the customer shall mark the RMA clearly on the outside of the 
package and include all cables and accessories purchased with the DrewLinQ along with any proof of purchase if 
available. 
 
A DrewLinQ is warranted for 90 days after a warranty repair, or to end of the original factory warranty period (or if 
an extended warranty was purchased, the extended warranty period), whichever is the longest.  
 
The limited warranty does not apply to: 

 Cosmetic damage such as scratches, nicks, and dents. 

 Damage caused by accident, abuse, misuse, water, flooding, fire, modification, or other acts of nature or 
external causes. 

 Damage caused by service by a non-authorized service provider of DrewTech. 

 Damage by connecting to cables not provided by DrewTech. 

 
DrewTech retains the exclusive right to repair or replace (with a new or newly overhauled replacement product) the 
device or offer a full refund of the purchase price at its sole discretion.  
 
SUCH REMEDY SHALL BE YOUR SOLE AND EXCLUSIVE REMEDY FOR ANY BREACH OF WARRANTY. 

17.2. Warranty Information - 90 Day Warranty on Cables 

Detachable cables for the DrewLinQ product are warranted for 90 days. 

17.3. Governance 

The user agrees to be governed by the laws of the State of Michigan, United States of America, and consents to 
the jurisdiction of the state court of Michigan in all disputes arising out of or relating to the use of this device. 

17.4. Contact 

Please direct all inquiries to:  
Drew Technologies, Inc. 
3915 Research Park Drive, Suite 10A 
Ann Arbor, MI 48108 
(734) 222-5228 

 
 


